Error using npapi plugin on 64bit chrome

\"\"

현재 크롬 데브채널을 사용하면 위에 보이는 것처럼 64bit 버전이라고 뜬다.

얼마전에 윈도우7,8 데브채널을 사용하는 사람들에게 크롬을 64bit 버전으로 그냥 올려버린것이다.

근데 여기서 문제가 발생하는데 금융사나 몇몇사이트들이 멀티브라우저 지원하겠다고 내놓은 플러그인들이 동작을 안한다.

 

일단 한번 업데이트가 끝나면 스테이블이나 베타채널로 바꿔도 롤백이 되지는 않으니 삭제후에 다시 설치를 해야한다. 아 귀찮아.


 

04일 수정

크로미움에 이슈등록을 했더니. 머지됐다고 메일이 왔다. 확인해보니 플러그인에서 64비트를 지원해야된다고… 플러그인 업데이트를 하란다 ㅠㅠ 그래서 넥슨이랑 금융사에 일단 문의를 보내둿다. 언제 업데이트 될지는 미지수.

그리고 크롬에서는 올해(2014)말까지 npapi를 아예 퇴출시킨다는 방향이라서 네이티브 어플리케이션과 통신은 nmapi 사용을 권장한덴다. 자세한건 모르니 링크만 걸어두고 끝내겟다.

http://www.chromium.org/developers/npapi-deprecation
http://developer.chrome.com/extensions/messaging.html#native-messaging